Back to overview
Degraded

Proofmarked website is down

Sep 21, 2025 at 05:22pm UTC
Affected services
Proofmarked website

Resolved
Sep 21, 2025 at 05:29pm UTC

Proofmarked website recovered.

Created
Sep 21, 2025 at 05:22pm UTC

Proofmarked website is degraded.